FilteredElementCollectorContainedInDesignOption Method |
Applies an ElementDesignOptionFilter to the collector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FilteredElementCollector ContainedInDesignOption(
ElementId designOptionId
)
Public Function ContainedInDesignOption (
designOptionId As ElementId
) As FilteredElementCollector
public:
FilteredElementCollector^ ContainedInDesignOption(
ElementId^ designOptionId
)
member ContainedInDesignOption :
designOptionId : ElementId -> FilteredElementCollector
Parameters
- designOptionId ElementId
-
The design option id.
Return Value
FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned
so you can chain multiple calls together in one line.
Exceptions
Remarks
Only elements that are contained by this particular design option will pass the collector.
If you have an active iterator to this collector it will be stopped by this call.
See Also