JoinGeometryUtilsUnjoinGeometry Method |
Removes a join between two elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void UnjoinGeometry(
Document document,
Element firstElement,
Element secondElement
)
Public Shared Sub UnjoinGeometry (
document As Document,
firstElement As Element,
secondElement As Element
)
public:
static void UnjoinGeometry(
Document^ document,
Element^ firstElement,
Element^ secondElement
)
static member UnjoinGeometry :
document : Document *
firstElement : Element *
secondElement : Element -> unit
Parameters
- document Document
-
The document containing the two elements.
- firstElement Element
-
The first element to be unjoined.
- secondElement Element
-
The second element to be unjoined. This element must be joined to the fist element.
ExceptionsException | Condition |
---|
ArgumentException |
document is not a project document.
-or-
The element firstElement was not found in the given document.
-or-
The element secondElement was not found in the given document.
-or-
The elements are not joined.
-or-
The elements cannot be unjoined.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels.
|
Remarks
This functionality is not available for family documents.
See Also