AnalyticalElementMaterialId Property

Defines the Material Id for the Analytical Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId MaterialId { get; set; }

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentException When setting this property: The provided MaterialId is not supported
ArgumentNullException When setting this property: A non-optional argument was null
See Also