ViewSheetGetCurrentRevision Method |
Returns the most recent numbered Revision shown on this ViewSheet.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetCurrentRevision()
Public Function GetCurrentRevision As ElementId
public:
ElementId^ GetCurrentRevision()
member GetCurrentRevision : unit -> ElementId
Return Value
ElementId
The Id of the most recent numbered Revision shown on this ViewSheet or InvalidElementId if none are shown.
Remarks
If the most recent Revision is not issued, Revit will typically use it as the default Revision for
RevisionClouds placed on this ViewSheet. InvalidElementId will be returned if no Revisions are present.
Revisions with RevisionNumberType.None will not be returned.
See Also