JoinGeometryUtilsIsCuttingElementInJoin Method |
Determines whether the first of two joined elements is cutting the second element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsCuttingElementInJoin(
Document document,
Element firstElement,
Element secondElement
)
Public Shared Function IsCuttingElementInJoin (
document As Document,
firstElement As Element,
secondElement As Element
) As Boolean
public:
static bool IsCuttingElementInJoin(
Document^ document,
Element^ firstElement,
Element^ secondElement
)
static member IsCuttingElementInJoin :
document : Document *
firstElement : Element *
secondElement : Element -> bool
Parameters
- document Document
-
The document containing the two elements.
- firstElement Element
-
The first element.
- secondElement Element
-
The second element.
Return Value
Boolean
True if the secondElement is cut by the firstElement, false if the secondElement is cut by the firstElement.
ExceptionsException | Condition |
---|
ArgumentException |
document is not a project document.
-or-
The element firstElement was not found in the given document.
-or-
The element secondElement was not found in the given document.
-or-
The elements are not joined.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
This functionality is not available for family documents.
See Also