FilteredElementCollector(Document, ICollectionElementId) Constructor |
Constructs a new FilteredElementCollector that will search and filter a specified set of elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FilteredElementCollector(
Document document,
ICollection<ElementId> elementIds
)
Public Sub New (
document As Document,
elementIds As ICollection(Of ElementId)
)
public:
FilteredElementCollector(
Document^ document,
ICollection<ElementId^>^ elementIds
)
new :
document : Document *
elementIds : ICollection<ElementId> -> FilteredElementCollector
Parameters
- document Document
-
The document that owns the elements matching the element ids.
- elementIds ICollectionElementId
-
The input set of element ids.
Exceptions
See Also