RebarShapeDefinitionAddParameter Method |
Add a parameter to the shape definition.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddParameter(
ElementId paramId,
double defaultValue
)
Public Sub AddParameter (
paramId As ElementId,
defaultValue As Double
)
public:
void AddParameter(
ElementId^ paramId,
double defaultValue
)
member AddParameter :
paramId : ElementId *
defaultValue : float -> unit
Parameters
- paramId ElementId
-
The parameter. To obtain the id of a shared parameter,
call RebarShapeParameters.GetElementIdForExternalDefinition.
- defaultValue Double
-
A default value for this parameter in shapes. The default values
should be chosen carefully, because they are required to be consistent as a set of constraints.
ExceptionsException | Condition |
---|
ArgumentException |
paramId is not the id of a shared parameter in the current document,
or its unit type is not UT_Reinforcement_Length or UT_Angle.
-or-
The name of a shared parameter identified by paramId
was already used by another shared parameter of the element.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
A shape parameter must be a shared parameter and have value type double.
A parameter must be added to the definition before it can be used to
drive the shape in a RebarShapeConstraint object.
A parameter that does not drive a constraint is legal and will
simply become an editable parameter on any Rebar that is an instance of this RebarShape.
See Also