SpatialElementGetBoundarySegments Method |
Returns the boundary segments.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<IList<BoundarySegment>> GetBoundarySegments(
SpatialElementBoundaryOptions options
)
Public Function GetBoundarySegments (
options As SpatialElementBoundaryOptions
) As IList(Of IList(Of BoundarySegment))
public:
IList<IList<BoundarySegment^>^>^ GetBoundarySegments(
SpatialElementBoundaryOptions^ options
)
member GetBoundarySegments :
options : SpatialElementBoundaryOptions -> IList<IList<BoundarySegment>>
Parameters
- options SpatialElementBoundaryOptions
- The SpatialElementBoundaryOptions.
Return Value
IListIListBoundarySegment
RemarksThis method is used to retrieve the segments that constitute the boundary of the spatial element.
Each spatial element may have several regions, each of which have several segments hence the data is returned
in the form of an array of boundary segment arrays. See the BoundarySegment object for more
details about the segments that make up the spatial element topology.
See Also