RebarFreeFormAccessorSetCurves(IListCurveLoop) Method |
Set the curves into a free form Rebar. Will throw exception if the rebar has valid constraints.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarFreeFormValidationResult SetCurves(
IList<CurveLoop> curves
)
Public Function SetCurves (
curves As IList(Of CurveLoop)
) As RebarFreeFormValidationResult
public:
RebarFreeFormValidationResult SetCurves(
IList<CurveLoop^>^ curves
)
member SetCurves :
curves : IList<CurveLoop> -> RebarFreeFormValidationResult
Parameters
- curves IListCurveLoop
-
Each curve loop represents a bar in the set.
Return Value
RebarFreeFormValidationResult
Returns Success if everything is ok, otherwise the failure reason.
Exceptions
RemarksThis function can fail due to following reasons:
- The array of CurveLoops is empty.
- At least one CurveLoop is empty.
- At least one CurveLoop contains an unbounded curve.
- A rebar constructed from curves can't be bent according to the bending radius.
See Also