BRepBuilderIsPermittedSurfaceType Method |
A validator function that checks whether the surface object is of type supported as face surface by BRepBuilder.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsPermittedSurfaceType(
Surface surface
)
Public Shared Function IsPermittedSurfaceType (
surface As Surface
) As Boolean
public:
static bool IsPermittedSurfaceType(
Surface^ surface
)
static member IsPermittedSurfaceType :
surface : Surface -> bool
Parameters
- surface Surface
-
Surface object intended to be used as a face surface.
Return Value
Boolean
True if a surface of this type may be used as a face surface, false otherwise.
Exceptions
Remarks
The allowed surface types are ConicalSurface, CylindricalSurface, Plane, RevolvedSurface, RuledSurface, and HermiteSurface.
See Also