ViewSheetGetAllViewports Method |
Returns the ElementIds of Viewports on this sheet.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> GetAllViewports()
Public Function GetAllViewports As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetAllViewports()
member GetAllViewports : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
The Viewports on this sheet.
Remarks
Schedules on the sheet are not returned by this method. Use ScheduleSheetInstance.OwnerViewId to find the sheet on which a schedule is placed.
See Also