BRepBuilderSetFaceMaterialId Method |
Sets material id to a face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetFaceMaterialId(
BRepBuilderGeometryId faceId,
ElementId materialId
)
Public Sub SetFaceMaterialId (
faceId As BRepBuilderGeometryId,
materialId As ElementId
)
public:
void SetFaceMaterialId(
BRepBuilderGeometryId^ faceId,
ElementId^ materialId
)
member SetFaceMaterialId :
faceId : BRepBuilderGeometryId *
materialId : ElementId -> unit
Parameters
- faceId BRepBuilderGeometryId
-
Id of the face to which material id will be added. faceId was returned by a call to AddFace().
- materialId ElementId
-
The material id associated with the face, or invalidElementId if none.
It is not verified that materialId corresponds to a valid Material element.
ExceptionsException | Condition |
---|
ArgumentException |
The supplied face id doesn't correspond to a face stored in this BRepBuilder object.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error.
Consult the State property of the BRepBuilder object for more details.
|
See Also