IFCGeometryInfoCreateCurveGeometryInfo Method |
Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IFCGeometryInfo CreateCurveGeometryInfo(
ExporterIFC ExporterIFC,
Transform lcs,
XYZ projectionDir,
bool planViewOnly
)
Public Shared Function CreateCurveGeometryInfo (
ExporterIFC As ExporterIFC,
lcs As Transform,
projectionDir As XYZ,
planViewOnly As Boolean
) As IFCGeometryInfo
public:
static IFCGeometryInfo^ CreateCurveGeometryInfo(
ExporterIFC^ ExporterIFC,
Transform^ lcs,
XYZ^ projectionDir,
bool planViewOnly
)
static member CreateCurveGeometryInfo :
ExporterIFC : ExporterIFC *
lcs : Transform *
projectionDir : XYZ *
planViewOnly : bool -> IFCGeometryInfo
Parameters
- ExporterIFC ExporterIFC
-
The exporter.
- lcs Transform
-
The local coordinate system that defines the plane in which the curve handles must lie.
- projectionDir XYZ
-
The normal vector to the input plane.
- planViewOnly Boolean
-
True to match curves with plan view visibility only, false to match curves regardless of their plan view visibility.
Return Value
IFCGeometryInfo
The new geometry info container.
Exceptions
See Also