ViewEnableTemporaryViewPropertiesMode Method |
Turns Temporary View Properties mode on or off. In this mode, any changes made to the view
are temporary and will be discarded once the mode is disabled.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool EnableTemporaryViewPropertiesMode(
ElementId viewTemplateId
)
Public Function EnableTemporaryViewPropertiesMode (
viewTemplateId As ElementId
) As Boolean
public:
bool EnableTemporaryViewPropertiesMode(
ElementId^ viewTemplateId
)
member EnableTemporaryViewPropertiesMode :
viewTemplateId : ElementId -> bool
Parameters
- viewTemplateId ElementId
-
If the id of a view template is provided, Temporary View Properties mode
is turned on and the settings from the template are applied to the view for the duration of the mode.
If the id provided is not that of a template but the id of the view itself,
Temporary View Properties mode is turned on without any changes to the view.
If ElementId.InvalidElementId is provided, Temporary View Properties mode is turned off.
Return Value
Boolean
Returns true when the view template provided by viewTemplateId was applied and Temporary View Properties was successfully turned on.
Also returns true if ElementId.InvalidElementId was provided as input and Temporary View Properties was successfully turned off.
Exceptions
See Also