FlexPipeIsPipingSystemTypeId Method

Checks if given type is valid piping system type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsPipingSystemTypeId(
	Document document,
	ElementId systemTypeId
)

Parameters

document  Document
The document.
systemTypeId  ElementId
ElementId of the piping system type to check.

Return Value

Boolean
True if the given systemTypeId is the piping system type, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also