NumberingSchemaShiftNumbers Method

Shifts all numbers in the sequence so the starting number has the given value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ShiftNumbers(
	string partition,
	int firstNumber
)

Parameters

partition  String
Name of the partition that identifies the sequence. The sequence must exist.
firstNumber  Int32
Value for the new first (lowest) number of the sequence.
Exceptions
ExceptionCondition
ArgumentException The sequence partition does not exist in the schema.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException firstNumber must be in range between 1 and MaximumStartingNumber.
InvalidOperationException Either the schema or its document cannot be modified at present.
Remarks

A shift of all numbers in the sequence will be computed and applied so the first (lowest) number in the sequence would have the given value. All the other numbers will then be shifted relatively by the same amount.

Any existing gaps in the current numbering sequence will be preserved.

Shifts that would make the start number less than 1 or bigger than MaximumStartingNumber are considered invalid.

See Also