ApplicationNewInstanceBinding(CategorySet) Method

Creates a new instance binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public InstanceBinding NewInstanceBinding(
	CategorySet categorySet
)

Parameters

categorySet  CategorySet
A set of categories that will be added to the binding.

Return Value

InstanceBinding
A new instance binding object.
Remarks
Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category.
See Also