LinkOperations Class

This class is used to extend the IExternalResourceServer interface with methods to support operations for elements that are LinkTypes.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LinkOperations : IDisposable

The LinkOperations type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the LinkOperations
Public methodSetOnLocalLinkSharedCoordinatesSavedCallback Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer.
Top
See Also