IExporterIFCExportIFC Method |
The method that Revit will invoke to perform an export to IFC.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxvoid ExportIFC(
Document document,
ExporterIFC exporter,
View filterView
)
Sub ExportIFC (
document As Document,
exporter As ExporterIFC,
filterView As View
)
void ExportIFC(
Document^ document,
ExporterIFC^ exporter,
View^ filterView
)
abstract ExportIFC :
document : Document *
exporter : ExporterIFC *
filterView : View -> unit
Parameters
- document Document
-
The document to export.
- exporter ExporterIFC
-
The IFC exporter object.
- filterView View
-
The view whose filter visibility settings govern the export.
Remarks
There will be a transaction group opened for the document. Any changes made to the document
must be temporary, as the transaction group will automatically be rolled back at the end.
See Also