TaskDialogShow(String, String, TaskDialogCommonButtons, TaskDialogResult) Method

Shows a task dialog with title, main instruction, common buttons and default buttons.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static TaskDialogResult Show(
	string title,
	string mainInstruction,
	TaskDialogCommonButtons buttons,
	TaskDialogResult defaultButton
)

Parameters

title  String
The title of the task dialog.
mainInstruction  String
The main instruction of the task dialog.
buttons  TaskDialogCommonButtons
The common buttons to be shown the task dialog.
defaultButton  TaskDialogResult
The default button of the task dialog.

Return Value

TaskDialogResult
The user's response to the task dialog.
See Also