TaskDialogResult Enumeration

Enum to specify the task dialog result.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum TaskDialogResult
Members
Member nameValueDescription
None0 Nothing is returned from the task dialog.
Ok1 The return value for TaskDialogCommonButtons.Ok.
Cancel2 The return value for TaskDialogCommonButtons.Cancel or the task dialog is cancelled by ESC, Alt+F4 or the X close button.
Retry4 The return value for TaskDialogCommonButtons.Retry.
Yes6 The return value for TaskDialogCommonButtons.Yes.
No7 The return value for TaskDialogCommonButtons.No.
Close8 The return value for TaskDialogCommonButtons.Close.
CommandLink11,001 The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink1.
CommandLink21,002 The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink2.
CommandLink31,003 The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink3.
CommandLink41,004 The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink4.
See Also