RebarCurvesDataAddBarGeometry(CurveLoop) Method |
Adds a new bar to the new rebar geometry. This information is set to the rebar after the API execution is finished successfully.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarFreeFormValidationResult AddBarGeometry(
CurveLoop curves
)
Public Function AddBarGeometry (
curves As CurveLoop
) As RebarFreeFormValidationResult
public:
RebarFreeFormValidationResult AddBarGeometry(
CurveLoop^ curves
)
member AddBarGeometry :
curves : CurveLoop -> RebarFreeFormValidationResult
Parameters
- curves CurveLoop
-
Curves describing one bar in the set.
Return Value
RebarFreeFormValidationResult
Returns Success if everything is ok, otherwise the failure reason.
Exceptions
RemarksThis function can fail due to following reasons:
- CurveLoop is empty.
- CurveLoop contains an unbounded curve.
- A rebar constructed from curves can't be bent according to the bending radius.
See Also