LoadBaseIsOrientToPermitted Method |
Indicates if the provided orientation is permitted for this load.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsOrientToPermitted(
LoadOrientTo orientTo
)
Public Function IsOrientToPermitted (
orientTo As LoadOrientTo
) As Boolean
public:
bool IsOrientToPermitted(
LoadOrientTo orientTo
)
member IsOrientToPermitted :
orientTo : LoadOrientTo -> bool
Parameters
- orientTo LoadOrientTo
-
Load orientation to check.
Return Value
Boolean
True if provided orientation type is permitted for this load, false if not.
Exceptions
Remarks
For hosted load only LoadOrientTo.Project and LoadOrientTo.HostLocalCoordinateSystem are permitted.
For non-hosted load only LoadOrientTo.Project and LoadOrientTo.WorkPlane are permitted.
To determine if load is hosted use
IsHosted property.
See Also