PathReinforcementConvertRebarInSystemToRebars Method |
Converts all RebarInSystem elements owned by the input PathReinforcement to equivalent Rebar elements.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> ConvertRebarInSystemToRebars(
Document doc,
PathReinforcement system
)
Public Shared Function ConvertRebarInSystemToRebars (
doc As Document,
system As PathReinforcement
) As IList(Of ElementId)
public:
static IList<ElementId^>^ ConvertRebarInSystemToRebars(
Document^ doc,
PathReinforcement^ system
)
static member ConvertRebarInSystemToRebars :
doc : Document *
system : PathReinforcement -> IList<ElementId>
Parameters
- doc Document
-
The document.
- system PathReinforcement
-
A PathReinforcement element in the document.
Return Value
IListElementId
The ids of the newly created Rebar elements.
Exceptions
See Also