ExternalDataInstanceAddingIntoDocumentEventArgs Class

The event arguments used by the ExternalDataInstanceAddingInto event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPIPreEventArgs
        Autodesk.Revit.DB.EventsRevitAPIPreDocEventArgs
          Autodesk.Revit.DB.EventsExternalDataInstanceAddingIntoDocumentEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalDataInstanceAddingIntoDocumentEventArgs : RevitAPIPreDocEventArgs

The ExternalDataInstanceAddingIntoDocumentEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs)
Public propertyDocument The document associated with the event.
(Inherited from RevitAPIPreDocEventArgs)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs)
Public propertyTypeId The type id of the newl external data instance that is being added.
Top
Methods
 NameDescription
Public methodCancel When the event is cancellable, may call the Cancel() method to cancel it.
(Inherited from RevitAPIPreEventArgs)
Public methodDispose
(Inherited from RevitAPIEventArgs)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also