RoutingPreferenceManagerRemoveRule Method |
Removes an existing routing preference rule.
Thrown if the index is out of bounds.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void RemoveRule(
RoutingPreferenceRuleGroupType groupType,
int index
)
Public Sub RemoveRule (
groupType As RoutingPreferenceRuleGroupType,
index As Integer
)
public:
void RemoveRule(
RoutingPreferenceRuleGroupType groupType,
int index
)
member RemoveRule :
groupType : RoutingPreferenceRuleGroupType *
index : int -> unit
Parameters
- groupType RoutingPreferenceRuleGroupType
-
The routing preference group type in which the rule should be removed.
- index Int32
-
The index position of removed routing preference rule in the group.
Exceptions
See Also