ComponentRepeaterCanElementBeRepeated Method |
Determines whether an element can be repeated using the RepeatElements method.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CanElementBeRepeated(
Document ADoc,
ElementId elementId
)
Public Shared Function CanElementBeRepeated (
ADoc As Document,
elementId As ElementId
) As Boolean
public:
static bool CanElementBeRepeated(
Document^ ADoc,
ElementId^ elementId
)
static member CanElementBeRepeated :
ADoc : Document *
elementId : ElementId -> bool
Parameters
- ADoc Document
-
The document containing the element.
- elementId ElementId
-
The element to be tested.
Return Value
Boolean
True if the element can be repeated.
Exceptions
Remarks
The element must be an adaptive family instance and have no shape handles.
At least one placement point must be hosted on a 1D or 2D repeating reference.
All other placement points can be hosted on a 0D, 1D or 2D repeating reference,
or must be unhosted.
See Also