DocumentNewUnionFitting Method |
Add a new family instance of an union fitting into the Autodesk Revit document,
using two connectors.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstance NewUnionFitting(
Connector connector1,
Connector connector2
)
Public Function NewUnionFitting (
connector1 As Connector,
connector2 As Connector
) As FamilyInstance
public:
FamilyInstance^ NewUnionFitting(
Connector^ connector1,
Connector^ connector2
)
member NewUnionFitting :
connector1 : Connector *
connector2 : Connector -> FamilyInstance
Parameters
- connector1 Connector
- The first connector to be connected to the union.
- connector2 Connector
- The second connector to be connected to the union.
Return Value
FamilyInstanceIf creation was successful then an family instance to the new object is returned,
otherwise an exception with failure information will be thrown.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the input argument connector1 or connector2 is .
|
ArgumentException |
Thrown when the connectors cannot be used for union creation. For example,
they cannot be from the same element, they must be of the same domain and shape,
and the owner of the connector1 should be a (flex) duct or pipe.
|
InvalidOperationException |
Thrown when union fitting cannot be created.
|
See Also