ScheduleSheetInstanceCreate(Document, ElementId, ElementId, XYZ) Method |
Create an instance of a schedule on a sheet.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ScheduleSheetInstance Create(
Document document,
ElementId viewSheetId,
ElementId scheduleId,
XYZ origin
)
Public Shared Function Create (
document As Document,
viewSheetId As ElementId,
scheduleId As ElementId,
origin As XYZ
) As ScheduleSheetInstance
public:
static ScheduleSheetInstance^ Create(
Document^ document,
ElementId^ viewSheetId,
ElementId^ scheduleId,
XYZ^ origin
)
static member Create :
document : Document *
viewSheetId : ElementId *
scheduleId : ElementId *
origin : XYZ -> ScheduleSheetInstance
Parameters
- document Document
-
The document
- viewSheetId ElementId
-
The id of the sheet where the schedule will be placed.
- scheduleId ElementId
-
The id of the schedule view.
- origin XYZ
-
Location on the sheet where the schedule will be placed.
Return Value
ScheduleSheetInstance
The new ScheduleInstance.
ExceptionsException | Condition |
---|
ArgumentException |
scheduleId is not a ViewSchedule that can be added to sheets. "Internal" schedules are not user-visible but are filtered by sheet or used to manage Revisions, which cannot be added to sheets.
-or-
viewSheetId is not a ViewSheet.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also