FieldDomainPointsByUV(IListUV, ICollectionDouble, ICollectionDouble) Constructor |
Creates object from an array of two-dimensional point coordinates
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FieldDomainPointsByUV(
IList<UV> points,
ICollection<double> uCoordinates,
ICollection<double> vCoordinates
)
Public Sub New (
points As IList(Of UV),
uCoordinates As ICollection(Of Double),
vCoordinates As ICollection(Of Double)
)
public:
FieldDomainPointsByUV(
IList<UV^>^ points,
ICollection<double>^ uCoordinates,
ICollection<double>^ vCoordinates
)
new :
points : IList<UV> *
uCoordinates : ICollection<float> *
vCoordinates : ICollection<float> -> FieldDomainPointsByUV
Parameters
- points IListUV
-
Array of two-dimensional point coordinates representing domain points (usually on surface)
- uCoordinates ICollectionDouble
-
Set of u coordinates at which to draw grid lines on the surface
- vCoordinates ICollectionDouble
-
Set of v coordinates at which to draw grid lines on the surface
Exceptions
See Also