AdaptiveComponentFamilyUtilsMakeAdaptivePoint Method

Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void MakeAdaptivePoint(
	Document doc,
	ElementId refPointId,
	AdaptivePointType type
)

Parameters

doc  Document
The Document
refPointId  ElementId
The ReferencePoint id
type  AdaptivePointType
The Adaptive Point Type
Exceptions
ExceptionCondition
ArgumentException The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException This operation failed.
See Also