CompoundStructureIsLayerValid Method |
Verifies that the data in this layer is internally consistent.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsLayerValid(
int layerIdx,
CompoundStructureLayer layer
)
Public Function IsLayerValid (
layerIdx As Integer,
layer As CompoundStructureLayer
) As Boolean
public:
bool IsLayerValid(
int layerIdx,
CompoundStructureLayer^ layer
)
member IsLayerValid :
layerIdx : int *
layer : CompoundStructureLayer -> bool
Parameters
- layerIdx Int32
-
The index of the layer in the compound structure to be set.
- layer CompoundStructureLayer
-
The layer to be set.
Return Value
Boolean
True if the layer is internally consistent, false if the layer is not internally consistent.
Exceptions
Remarks
If the layer function is not Membrane or StructuralDeck, the width must be greater than zero.
If the layer function is not StructuralDeck, then the deck embedding type must be Invalid, and the deck profile id must be InvalidElementId.
See Also