FilteredElementCollectorExcluding Method |
Applies an ExclusionFilter to the collector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FilteredElementCollector Excluding(
ICollection<ElementId> idsToExclude
)
Public Function Excluding (
idsToExclude As ICollection(Of ElementId)
) As FilteredElementCollector
public:
FilteredElementCollector^ Excluding(
ICollection<ElementId^>^ idsToExclude
)
member Excluding :
idsToExclude : ICollection<ElementId> -> FilteredElementCollector
Parameters
- idsToExclude ICollectionElementId
-
The ids to exclude from the results.
Return Value
FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned
so you can chain multiple calls together in one line.
Exceptions
Remarks
Elements passed to this filter will be automatically excluded from the results.
If you have an active iterator to this collector it will be stopped by this call.
See Also