FamilyUtilsGetProfileSymbols Method |
Gets the profile Family Symbols of the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ICollection<ElementId> GetProfileSymbols(
Document document,
ProfileFamilyUsage profileFamilyUsage,
bool oneCurveLoopOnly
)
Public Shared Function GetProfileSymbols (
document As Document,
profileFamilyUsage As ProfileFamilyUsage,
oneCurveLoopOnly As Boolean
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetProfileSymbols(
Document^ document,
ProfileFamilyUsage profileFamilyUsage,
bool oneCurveLoopOnly
)
static member GetProfileSymbols :
document : Document *
profileFamilyUsage : ProfileFamilyUsage *
oneCurveLoopOnly : bool -> ICollection<ElementId>
Parameters
- document Document
-
The document.
- profileFamilyUsage ProfileFamilyUsage
-
The profile family usage.
- oneCurveLoopOnly Boolean
-
Whether or not to return only profiles with one curve loop.
Return Value
ICollectionElementId
The set of profile Family Symbol element ids.
Exceptions
See Also