ReferenceIntersector(ElementId, FindReferenceTarget, View3D) Constructor

Constructs a ReferenceIntersector which is set to return intersections from a single target element only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ReferenceIntersector(
	ElementId targetElementId,
	FindReferenceTarget targetType,
	View3D view3d
)

Parameters

targetElementId  ElementId
The target element id.
targetType  FindReferenceTarget
The target type of references to return.
view3d  View3D
The view in which to find references.
Exceptions
ExceptionCondition
ArgumentException Returns true if the view is not a view template.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also