ParameterFilterUtilitiesGetFilterableParametersInCommon Method |
Returns the filterable parameters common to the given categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ICollection<ElementId> GetFilterableParametersInCommon(
Document aDoc,
ICollection<ElementId> categories
)
Public Shared Function GetFilterableParametersInCommon (
aDoc As Document,
categories As ICollection(Of ElementId)
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetFilterableParametersInCommon(
Document^ aDoc,
ICollection<ElementId^>^ categories
)
static member GetFilterableParametersInCommon :
aDoc : Document *
categories : ICollection<ElementId> -> ICollection<ElementId>
Parameters
- aDoc Document
-
The document containing the categories and parameters to query.
- categories ICollectionElementId
-
The categories for which to determine the common parameters.
Return Value
ICollectionElementId
The set of filterable parameters common to the given categories.
Exceptions
RemarksA filterable category in Revit has a set of filterable parameters.
The filterable parameters common to a set of categories is the
intersection of all these filterable parameter sets.
This set defines the set of parameters that may be used to define
a rule on a ParameterFilterElement with a certain set of categories.
See Also