RebarCurvesDataSetDistributionPath Method |
Sets a new distribution path to be applied to the rebar. This information is set to the rebar after the API execution is finished successfully.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetDistributionPath(
IList<Curve> path
)
Public Sub SetDistributionPath (
path As IList(Of Curve)
)
public:
void SetDistributionPath(
IList<Curve^>^ path
)
member SetDistributionPath :
path : IList<Curve> -> unit
Parameters
- path IListCurve
-
Input curves that describe the new path.
Exceptions
Remarks
For a free form rebar set the distance between two consecutive bars may be different if it is calculated between different points on bars.
The distribution path is an array of curves with the property that based on these curves the set was calculated to respect the layout rule and number of bars or spacing.
See Also