ConceptualSurfaceTypeDefaultConstructionTypeId Property |
The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId DefaultConstructionTypeId { get; set; }
Public Property DefaultConstructionTypeId As ElementId
Get
Set
public:
property ElementId^ DefaultConstructionTypeId {
ElementId^ get ();
void set (ElementId^ value);
}
member DefaultConstructionTypeId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The input element is not a constructionType.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also