TextElementGetMaximumAllowedWidth(Document, ElementId) Method |
Returns the maximum width the text element can be created with.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static double GetMaximumAllowedWidth(
Document cdda,
ElementId typeId
)
Public Shared Function GetMaximumAllowedWidth (
cdda As Document,
typeId As ElementId
) As Double
public:
static double GetMaximumAllowedWidth(
Document^ cdda,
ElementId^ typeId
)
static member GetMaximumAllowedWidth :
cdda : Document *
typeId : ElementId -> float
Parameters
- cdda Document
-
A document containing the new text element's type
- typeId ElementId
-
Id of the text type
Return Value
Double
The maximum allowed width in paper space [ft].
Exceptions
Remarks
Note that it is not necessarily a constant; it can be affected
by properties of the text type, such as the width factor.
See Also