RebarBarTypeGetStaggerLength Method |
Gets the stagger length taking into account the specified Rebar Splice Type.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetStaggerLength(
ElementId rebarSpliceTypeId
)
Public Function GetStaggerLength (
rebarSpliceTypeId As ElementId
) As Double
public:
double GetStaggerLength(
ElementId^ rebarSpliceTypeId
)
member GetStaggerLength :
rebarSpliceTypeId : ElementId -> float
Parameters
- rebarSpliceTypeId ElementId
-
The Rebar Splice Type id.
Interactions with Rebar Splice Types can be done with the functions in RebarSpliceTypeUtils.
Return Value
Double
Returns the stagger length.
ExceptionsException | Condition |
---|
ArgumentException |
The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
|
ArgumentNullException |
A non-optional argument was null
|
See Also