RadialArrayCreate(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) Method

Creates a new radial array element from a single element based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static RadialArray Create(
	Document aDoc,
	View dBView,
	ElementId id,
	int count,
	Line axis,
	double angle,
	ArrayAnchorMember anchorMember
)

Parameters

aDoc  Document
The document.
dBView  View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id  ElementId
The element to array. The position of the rotation axis is determined by the center of the element's bounding boxes.
count  Int32
The number of array members to create. The accepted range is from 3 to 200 in a project document, and between 0 and 200 in a family document.
axis  Line
The rotation axis.
angle  Double
The angle in radians of the rotation.
anchorMember  ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

RadialArray
The new radial array element.
Exceptions
ExceptionCondition
ArgumentException The element id does not exist in the document -or- id is not arrayable. -or- count must be between 3 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the element. -or- Angle value must be not zero.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Failed to create the radial array.
See Also