IFamilyLoadOptionsOnSharedFamilyFound Method |
A method called when the shared family was found in the target document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool OnSharedFamilyFound(
Family sharedFamily,
bool familyInUse,
out FamilySource source,
out bool overwriteParameterValues
)
Function OnSharedFamilyFound (
sharedFamily As Family,
familyInUse As Boolean,
<OutAttribute> ByRef source As FamilySource,
<OutAttribute> ByRef overwriteParameterValues As Boolean
) As Boolean
bool OnSharedFamilyFound(
Family^ sharedFamily,
bool familyInUse,
[OutAttribute] FamilySource% source,
[OutAttribute] bool% overwriteParameterValues
)
abstract OnSharedFamilyFound :
sharedFamily : Family *
familyInUse : bool *
source : FamilySource byref *
overwriteParameterValues : bool byref -> bool
Parameters
- sharedFamily Family
-
The shared family in the current family document.
- familyInUse Boolean
-
Indicates if one or more instances of the family is placed in the project.
- source FamilySource
-
This indicates if the family will load from
the project or the current family.
- overwriteParameterValues Boolean
-
This indicates whether or not to overwrite the parameter
values of existing types.
Return Value
Boolean
Return true to continue loading the family, false to cancel.
Remarks
Triggered only when the family is both loaded and changed.
See Also