ParameterFilterElementGetElementFilterParametersForCategory Method |
Retrieves a list of the parameters associated with all rules in the filter
that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ISet<ElementId> GetElementFilterParametersForCategory(
ElementId categoryId
)
Public Function GetElementFilterParametersForCategory (
categoryId As ElementId
) As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetElementFilterParametersForCategory(
ElementId^ categoryId
)
member GetElementFilterParametersForCategory :
categoryId : ElementId -> ISet<ElementId>
Parameters
- categoryId ElementId
-
The category for which parameters should be found.
Return Value
ISetElementId
A set of parameter identifiers.
Exceptions
Remarks
Note that in the case when InvalidElementId specified as input %categoryId% this function returns
parameters common to all categories used by this ParameterFilterElement,
i.e. it is equivalent to ParameterFilterElement.GetElementFilterParameters().
See Also