DocumentExport(String, String, ICollectionElementId, DGNExportOptions) Method |
Exports a selection of views in DGN format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Export(
string folder,
string name,
ICollection<ElementId> views,
DGNExportOptions options
)
Public Function Export (
folder As String,
name As String,
views As ICollection(Of ElementId),
options As DGNExportOptions
) As Boolean
public:
bool Export(
String^ folder,
String^ name,
ICollection<ElementId^>^ views,
DGNExportOptions^ options
)
member Export :
folder : string *
name : string *
views : ICollection<ElementId> *
options : DGNExportOptions -> bool
Parameters
- folder String
-
Output folder, into which file(s) will be exported. The folder must exist.
- name String
-
Either the name of a single file or a prefix for a set of files.
If empty, automatic naming will be used.
If , throw ArgumentException.
- views ICollectionElementId
-
Selection of views to be exported. The set must contain at least one valid view.
- options DGNExportOptions
-
Various options applicable to the DGN format.
If , all options will be set to their respective default values.
Return Value
Boolean
True if successful, otherwise False.
Exceptions
Remarks
All the views must be printable for the Export to succeed.
It can be assured by checking the CanBePrinted property of each view.
Examplepublic bool ExportDGN(Document document, View view)
{
bool exported = false;
IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
if (setupNames.Count > 0)
{
DGNExportOptions dgnOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames[0]);
if (view.CanBePrinted == true)
{
ICollection<ElementId> views = new List<ElementId>();
views.Add(view.Id);
exported = document.Export(Path.GetDirectoryName(document.PathName),
Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions);
}
}
return exported;
}
Public Function ExportDGN(document As Document, view As View) As Boolean
Dim exported As Boolean = False
Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
If setupNames.Count > 0 Then
Dim dgnOptions As DGNExportOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames(0))
If view.CanBePrinted = True Then
Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
views.Add(view.Id)
exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions)
End If
End If
Return exported
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also