RevitLinkTypeGetTopLevelLink(Document, ModelPath) Method |
Returns the ElementId of the (top-level) linked model with the given path.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId GetTopLevelLink(
Document document,
ModelPath path
)
Public Shared Function GetTopLevelLink (
document As Document,
path As ModelPath
) As ElementId
public:
static ElementId^ GetTopLevelLink(
Document^ document,
ModelPath^ path
)
static member GetTopLevelLink :
document : Document *
path : ModelPath -> ElementId
Parameters
- document Document
-
The document to look for the linked model in.
- path ModelPath
-
A path indicating which linked model to return.
Return Value
ElementId
The id of the link with the given path, or InvalidElementId if
there is no top-level link at that path.
Exceptions
Remarks
This function will not return nested links.
See Also