RebarShapeConstraint180DegreeDefaultBend Class

A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The arc's radius is not specified by the shape; instead it is a "default bend radius," taken from the RebarBarType associated with the Rebar instance.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureRebarShapeConstraint
    Autodesk.Revit.DB.StructureRebarShapeConstraint180DegreeDefaultBend

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraint180DegreeDefaultBend : RebarShapeConstraint

The RebarShapeConstraint180DegreeDefaultBend type exposes the following members.

Constructors
 NameDescription
Public methodRebarShapeConstraint180DegreeDefaultBend Create a 180-degree bend constraint.
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Top
See Also