RebarShapeConstraint180DegreeDefaultBend Class

A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The arc's radius is not specified by the shape; instead it is a "default bend radius," taken from the RebarBarType associated with the Rebar instance.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureRebarShapeConstraint
    Autodesk.Revit.DB.StructureRebarShapeConstraint180DegreeDefaultBend

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraint180DegreeDefaultBend : RebarShapeConstraint

The RebarShapeConstraint180DegreeDefaultBend type exposes the following members.

Constructors
 NameDescription
Public methodRebarShapeConstraint180DegreeDefaultBend Create a 180-degree bend constraint.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RebarShapeConstraint)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RebarShapeConstraint)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetParamId Return the Id of the parameter associated with this constraint.
(Inherited from RebarShapeConstraint)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also