WallCrossSection Property |
Gets or sets the Cross-section for this wall.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic WallCrossSection CrossSection { get; set; }
Public Property CrossSection As WallCrossSection
Get
Set
public:
property WallCrossSection CrossSection {
WallCrossSection get ();
void set (WallCrossSection value);
}
member CrossSection : WallCrossSection with get, set
Property Value
WallCrossSection
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The current wall does not support the cross section wallCrossSection.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
This value determines whether the wall is vertical, slanted or tapered. See also:
WallCrossSection.
Setting the value to "SingleSlanted" or "Tapered" will enable other parameters to control the slanted angle(s) for a slanted or a tapered wall.
See Also