WallCrossSection Enumeration |
The allowed values for the WALL_CROSS_SECTION parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum WallCrossSection
Public Enumeration WallCrossSection
public enum class WallCrossSection
MembersMember name | Value | Description |
---|
SingleSlanted | 0 |
A single-slanted wall whose angle is controlled by the parameter WALL_SINGLE_SLANT_ANGLE_FROM_VERTICAL.
|
Vertical | 1 |
A vertical wall, 0 degrees.
|
Tapered | 2 |
A tapered wall whose angle is controlled by the parameters
WALL_TAPERED_EXTERIOR_INWARD_ANGLE and WALL_TAPERED_INTERIOR_INWARD_ANGLE.
|
See Also