AddInIdGetAddInNameFromDocument Method |
name of application associated with this ApplicationId
First attempts to obtain the name from AddInIds stored in the document.
If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string GetAddInNameFromDocument(
Document aDoc
)
Public Function GetAddInNameFromDocument (
aDoc As Document
) As String
public:
String^ GetAddInNameFromDocument(
Document^ aDoc
)
member GetAddInNameFromDocument :
aDoc : Document -> string
Parameters
- aDoc Document
-
target document
Return Value
String
name of application
Exceptions
See Also