UpdaterRegistryAddTrigger(UpdaterId, ElementFilter, ChangeType) Method |
Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void AddTrigger(
UpdaterId id,
ElementFilter filter,
ChangeType change
)
Public Shared Sub AddTrigger (
id As UpdaterId,
filter As ElementFilter,
change As ChangeType
)
public:
static void AddTrigger(
UpdaterId^ id,
ElementFilter^ filter,
ChangeType^ change
)
static member AddTrigger :
id : UpdaterId *
filter : ElementFilter *
change : ChangeType -> unit
Parameters
- id UpdaterId
-
Id of updater that trigger should be added to
- filter ElementFilter
-
Element filter that defines elements that affect this trigger
- change ChangeType
-
ChangeType associated with this trigger
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The updater's owner's AddIn does not match the currently active AddIn.
-or-
The id does not correspond to any registered Updaters.
-or-
AddTrigger called while executing an updater.
|
Remarks
This method only works with CategoryFilter and ParameterFilter.
See Also